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e S I G N A L  B A S I C S
eSIGNAL IS DESIGNED so that you can tailor it to your own particular 
needs and preferences. Just as the broad selection of subscription ser-
vices enables you to pick and choose the data you’ll receive, the eSig-
nal application lets you determine how that data will be organized and 
presented. 

With a few exceptions (which we’ll point out), eSignal functions much like other 
standard Windows applications. If you have worked with Windows and other appli-
cations and feel comfortable with your ability to get things done, you may want to 
skim this section quickly and move on. On the other hand, if you’re new to Windows, 
this chapter reviews the basic concepts behind organizing and displaying data and 
explains the nuts-and-bolts features of eSignal. 

 If this is your first foray into Windows and you’re frustrated and bewildered, you 
may want to take a break and check out Getting Started in Windows Help. In Win-
dows 98 or Windows 2000, just click the Start button and then Help. In the Contents 
tab, choose the Getting Started Book.
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Starting and Exiting the Application
You start and stop eSignal like any other Windows application. The only slightly 
tricky thing to keep in mind is that the Data Manager must be running before you’ll 
get any data. Fear not, eSignal automatically starts the Data Manager for you if it 
isn’t already running. 

You need to establish an Internet connection before you start eSignal (see Chapter 4, 
Connecting to the Internet).

You can start eSignal via the Start menu, but the simplest way is to double-click the 
desktop icon that is added during the installation.

To start the application 

l Double-click the eSignal icon on your desktop. 

The eSignal application window appears. If the Data Manager isn't already run-
ning, it starts automatically. After a few seconds, data begins to appear in eSig-
nal. 
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NOTE: The first time you run eSignal, you’ll be presented with a default layout 
similar to that shown above. Later in this Chapter, you’ll learn how to open other 
sample layouts, as well as how to create and save your own layouts.

Exiting from eSignal
When you’re working in eSignal, you are actually running two and sometimes three 
applications. So in addition to the standard Exit command in the File menu, which 
simply closes eSignal, there is an Exit All and Save command. Exit All and Save 
closes eSignal, the Data Manager, and the Text Manager if it’s open. The command 
also saves any changes you’ve made to windows or layouts (more about these later). 

Use the normal Exit command if you want to leave the Data Manager running; use 
Exit All and Save if you want to shut everything down.
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To exit from the application

1 Choose Exit from the File menu or close the main application window using the 
standard close icon in the title bar.

If there are changes to the layout or any windows, a dialog box asks if you want 
to save the changes. 

2 Click Yes to save your changes or No not to save them. If you’ve made changes 
to more than one window and want to save them all, click Yes to All.

To exit all applications and save changes

Click Exit All and Save from the File menu (Ctrl-E).

Anatomy of the Application Window
When you open eSignal, it displays a main or application window, which in turn con-
tains individual data windows—Quote windows, Chart windows, and so on.

The application window (Figure 5-1) includes menus, a toolbar, and other features 
you’ll use to get things done in eSignal. 
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Title Bar 

The title bar is located at the very top of the application window. It shows the appli-
cation name and current layout. It also includes the standard Windows controls for 
minimizing, resizing, and closing the application window.

Figure 5-1. eSignal Application Window
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Status Bar 

The status bar, located at the bottom of the application window, provides important 
status information. Pay particular attention to the password and reception indicators 
on the far right. If they’re not displaying “OK,” then you may not be receiving data. 
The total symbol indicator on the status bar keeps track of the symbol count for the 
whole layout so that 50/100 symbol eSignal subscribers know when they are getting 
close to their limit without having to open the Data Manager application. The line 
number indicator shows what window line your cursor is on and the Alert Indicator 
displays when one or more limit alerts have been triggered.

Menu Line
The menu line sits just below the title bar. The menus provide access to the com-
mands that you’ll use as you work with eSignal. You’ll notice that the menu selection 
changes depending on which window you are working in. For example, if you’re 
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working in a Quote window, the menu bar includes a Quote Options menu. If the 
Ticker window is active, you’ll see a Ticker Options menu. 

To open a menu and select a command

1 Click the menu name from the menu bar. The commands available from the 
menu appear in a drop-down box.

2 Click the command name from the list.

NOTE: Sometimes a command appears “grayed-out.” This means that it’s not avail-
able. This occurs if the command doesn’t apply to the window you’re working in or 
if your subscription service level doesn’t entitle you to use the command.
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Toolbar
The toolbar sits below the menu bar. Clicking an icon in the toolbar is a shortcut to 
the menu commands you’ll use most frequently. 

Here’s a brief description of what each icon does:

Symbol Box

Shortcut for linking the symbol in the drop-down symbol box to 
other windows.

Shortcut for creating a new eSignal window.

Shortcut for creating a new Chart window.

Shortcut for creating a new Portfolio window.

Shortcut for opening a file.

Shortcut for saving the active window.

Cuts the highlighted symbol.

Copies the highlighted symbol to the clipboard.

Pastes a symbol from the clipboard into the active window.

Shortcut for printing the active window

Shortcut for finding a symbol in the active window.

Shortcut for opening the Text Manager and displaying all head-
lines.

Shortcut for opening the Text Manager and displaying a report list.
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Shortcut for accessing Dow Jones Hot News stories

Shortcut for opening and closing the Leaders window

Shortcut for inserting an autolist or option chain for the highlighted 
symbol.

Shortcut for opening the All Alerts dialog box 

Symbol Lookup shortcut

Activates the Help pointer.

Opens a Browser window linking you to eSignal Web Resources 
such as news, research, etc.

Opens a Browser window containing your broker’s web page. If 
you haven’t already set up the Trade! button, you’ll be presented 
with instructions for configuring it. 

Opens a Browser window containing the eSignal Pro web site (for 
eSignal Pro subscribers only).
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Layouts
A layout is an arrangement of data windows within the main application window. 
Layouts include the windows that are open, their size, and their position.

Figure 5-2 is an example of an eSignal layout. 

You can use the Layout menu to access a variety of sample layouts for particular 
screen resolutions as well as custom layouts that you create and save yourself.

Figure 5-2. Sample eSignal Layout
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Working with Windows
Once you start using eSignal, you’ll probably want to change how the windows on 
your screen appear. You’ll find it easy to open and close windows, and even to 
change a window’s size, position, colors and type styles. 

Let’s take a quick look at how you accomplish these basic tasks. As you read about 
the different window types in the succeeding chapters, you’ll discover even more 
ways to tailor the look and feel of a specific window type. 

Opening, Saving, and Closing Windows
Opening, saving, and closing windows are activities that all start from the File menu. 
The commands and steps you’ll use are much the same as those of any other win-
dows application. Here’s a description of the basic File menu commands you’ll use 
to open, save, and close windows:

To open a new window

1 Choose New from the File menu (Alt-F, N or Ctrl-N), and the New dialog box 
appears.

2 Click the window type from the list, and then click OK. A new window of the 
type you selected appears on your screen, ready to use. 

To open an existing window

1 Choose Open from the File menu (Alt-F, O or Ctrl-O) or click the File Open tool-
bar icon to display the Open dialog box.

2 Choose a file type from the Files of type drop-down list to display files of a par-
ticular type.

3 Double-click the file you want from the file list or click the file name and then 
click Open. 
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To save a window

l Click inside the window to make sure it is active, and then choose Save from the 
File menu (Alt-F, S).

To save a new window or an existing window to a new file

1 Click inside the window to make sure it is active, and then choose Save As from 
the File menu (Alt-F, A).

2 Enter a file name for the window, and then click Save. 

To close a window

1 Click inside the window to make sure it is active, and then choose Close from the 
File menu (Alt-F, C) or the Close icon on the window’s title bar. 

The window will close unless you’ve made changes, in which case you’ll be 
prompted to save your changes.

2 Click Yes to save your changes and close the window, or click No to close the 
window without saving your changes.

Resizing Windows
You can resize windows, making them bigger or smaller, to fit your screen and lay-
out. The new size and orientation are saved when you save the window and layout.

To resize windows

1 Position the cursor on a side or corner of the window. The cursor changes to a 
two-headed arrow.

2 Hold down the left mouse button and drag the corner or side. If you drag a side, 
the window size changes only on the side you are dragging. If you drag a corner, 
the two sides that form the corner change size together.

3 Release the mouse button when the window is the size you want.

You can also use the Maximize and Restore buttons on a window’s title bar to toggle 
between the window’s current size and a full screen view. This is handy if you want 
to view more data without having to scroll. 
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Moving Windows
You can move windows to place them wherever they're most convenient. Your new 
window placement is saved when you save the window arrangement or layout. 

To move a window

1 Click in the title bar of a window. If the window’s title bar is turned off, go to the 
window’s Options menu and turn it on to make it visible. 

2 Hold down the left mouse button and drag the window to the location you want.

Cascade and Tile
The Window menu includes two powerful commands that allow you to rearrange all 
the open windows at once. 

l Cascade (Alt-W, C). The Cascade command layers the windows on top of each 
other in an overlapping arrangement. Only the top window is completely visible. 
To view another window, you’ll need to click on its title bar to move it to the top.

l Tile (Alt-W, T). The Tile command displays all the open windows side by side, 
without overlap.

Changing Colors and Fonts
It’s easy to change color and text characteristics for a window. For example, you can 
change background colors or increase the size of text to make a window more pleas-
ing to view and easier to read. 

The Colors and Fonts commands are available from the option menu or in some 
cases by right-clicking inside the window (more about right-clicking later). When 
you select either of these commands, you will be presented with a dialog box where 
you can make your changes.

 For more detailed information, click Help in the Colors or Fonts Dialog boxes.
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Saving Defaults
This is a great time saver. Say you’ve created a window that really meets your needs. 
It’s the right size and in the right location on your screen. The colors, fonts, and grid-
lines are perfect. You can choose Save Defaults from the Options menu and save the 
window’s characteristics as the default for the window type; then every time you cre-
ate a new window of that type, it will display with the same attributes.

Right-Clicking
As you’re becoming familiar with eSignal, try right-clicking your mouse button on 
the different components of each window. Right-clicking is a shortcut for getting 
work done. When you right-click from within any window, you’ll be presented with 
a menu of commands from which you can choose. The actions you can take depend 
on the window type and where you clicked within the window. For example, if you 
right-click on a symbol in a Quote window, your choices look a lot different than if 
you right-click a column header. 

The commands that pop up when you right-click a symbol or its data row are associ-
ated with the symbol. For example, if you right-click IBM and choose Detail window 
from the pop-up menu, a Detail window displaying IBM’s data opens. 

Figure 5-3 shows the menu you’d see by right-clicking a symbol in a Quote window. 
The symbol pop-up menus in other windows are the same or a subset of the menu 
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shown in the figure. Commands that are grayed out either don’t apply to the window 
or issue, or are not part of your subscription service. 

Here’s where each of the commands leads you:

l News. Choosing News starts up the Text Manager and displays headlines that 
apply to the issue.

l NASDAQ Level II. This is available only for NASDAQ issues. It opens a NAS-
DAQ Level II window for the selected issue. 

l Quote Montage. This option is visible when you right click on a listed NYSE or 
AMEX issue. It opens a Level II window and displays both exchange listed and 
regional stock quotes for the selected issue.

l Option Chain. Choosing Option Chain automatically lists options data for the 
underlying symbol.

l Autolist. This is only available for NYSE or AMEX listed issues or futures. It 
opens a new Quote window that displays current regional quotes for the selected 
NYSE or AMEX issue or active contracts for the selected futures contract.

Figure 5-3. Right-click Pop-Up Menu for a Data Row
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l Daily History. This lets you create a new Chart window from a selection of daily 
history chart types.

l Intraday History. This lets you create a new Chart window from a selection of 
intraday history chart types. 

l Advanced Chart. This lets you create a new Advanced Chart window which sup-
ports enhanced scaling, custom formulas and studies.

l Detail window. Choosing Detail displays detail information in a Detail window. 

l Fundamental. Choosing Fundamental displays fundamental data in a Detail win-
dow.

l Island Book. Choosing Island Book lets you view after-hours trading data for 
stocks traded on the Island ECN.

l Research. This lets you view research information from a variety of online 
sources.When you select a source the browser window displays information for 
the source and symbol you selected.

l Set Alert. Choosing Set Alert lets you set an alert for the issue you selected. 

l Edit. Edit is a shortcut method for accessing the commands on the Edit menu.

l Trade. Choosing Trade starts a separate application that takes you directly into 
your brokerage account.This option is available only if you have an account with 
an online brokerage that accepts direct trading commands from eSignal. See 
Chapter19, Integrated Trading Features.

The commands that pop up when you right-click other windows provide shortcuts for 
editing. The actual commands vary depending on the window and component. For 
example, when you right-click in a Chart window, your choices may include chang-
ing colors or fonts, and drawing trendlines. By contrast, when you right-click a col-
umn heading in a Quote window, you see all the commands for editing a column 
heading.

Figure 5-4 shows what the pop-up menu looks like if you right-click on a Quote win-
dow column heading. 
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Working with Layouts
eSignal includes a selection of sample layouts. These sample layouts are designed to 
highlight various types of data and are optimized for different display resolutions. 
All the available layouts-the sample layouts supplied with the program as well as 
those you have saved-appear in the Layouts menu. When you want to display a dif-
ferent layout, just go to the Layout menu and click the layout you want.

Use the sample layouts to learn about the capabilities and characteristics of the dif-
ferent window types. Once you’re comfortable, you can create your own layouts by 
setting up windows to suit your needs; then save the layout (Alt-F, E). You can also 
use the samples as a starting point for creating new layouts. You can change symbols 
in the sample windows, remove unwanted windows and add new ones, resize and 
reposition windows, and then save them as a new layout (Alt-F, Y). 

Figure 5-4.  Right-Click Pop-Up Menu for a Column Heading
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Whenever you change a layout, you’ll need to save your changes to the layout to 
make them available for later use. You can save a layout to its existing name by 
choosing Save Layout from the Layout menu or you can leave the existing layout 
unchanged and create a new layout that includes the current changes by choosing 
Save Layout As from the Layout menu and giving it a new name.

Printing and Previewing
Printing and previewing in eSignal are similar to printing and previewing in other 
Windows applications. Unlike other applications, however, eSignal gives you the 
flexibility to define print settings for each window type. 

To print a window

1 Click inside the window to make sure it’s the active window. 

2 Choose Print from the File menu (Alt-F, P or Ctrl-P). Alternatively, click the 
Print toolbar icon.

The Print dialog box appears. 
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3 Make any of the following changes to match your printing requirements:

– Choose a different printer from the pull-down list.

– Choose a range of pages to print.

– Change the number of copies to be printed.

4 Click OK to print the window contents.

You can preview what a document will look like before you print it. The document is 
displayed in a special Print Preview window. You can move through the document 
with the Next Page or Previous Page button, see two pages at once with the Two 
Page button, zoom in and out with the Zoom In and Zoom Out buttons, and print the 
document with the Print button.

To preview a document

1 Click inside the window to make sure it’s the active window. 

2 Choose Print Preview from the File menu (Alt-F, V).

The window’s content is displayed on your screen as it would appear when 
printed. 
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3 When you’re finished looking at the document, click the Print button to print the 
document or click the Close button. Either action closes the Print Preview win-
dow and returns you to the application window.

You can specify print settings for a particular print job or for a particular window 
type.

To set printer options

1 Click inside the window to make sure it’s the active window. 

2 Choose Print Setup from the File menu (Alt-F, R).

The Print Setup dialog box appears. 
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3 Make any of the following changes to match your printing requirements:

– Choose a different printer from the Name pull-down list.

– Choose a paper size and source.

– Choose a page orientation.

4 Click the Settings button to set options for each window type. The tab for the 
window you’re printing should appear on top. If it isn’t, click it and modify the 
settings to meet your needs. 
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5 When you’re finished, Click OK to return to Print Setup and OK again to save 
the settings.

 See online Help for each of the tabs in the Print Settings dialog box for detailed 
information.

Resetting Databases
On rare occasions, communication problems cause your eSignal data to get out of 
sync with the eSignal database from which the data comes. This may result in bad 
data for an issue or may even lock up the data feed. You can resolve the problem and 
refresh your data by resetting your databases.

Use one of the following methods to reset your databases

1 Select Preferences from the File menu. Click the Clear Cache button then click 
OK to close the dialog box. 

2 While you are connected to eSignal, open the Data Manager window by clicking 
the Data Manager button on the Windows taskbar at the bottom of your screen.
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3 Choose Symbols from the Data menu. The Symbols dialog box appears. 

4 Click Reset DBs. This clears all symbols and data from the Data Manager data-
bases. Symbols listed in active Signal windows are then automatically reinserted 
into Data Manager from the eSignal databases.
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